Debian DSA-4109-1 : ruby-omniauth - security update

Medium Nessus Plugin ID 106727

Synopsis

The remote Debian host is missing a security-related update.

Description

Lalith Rallabhandi discovered that OmniAuth, a Ruby library for implementing multi-provider authentication in web applications, mishandled and leaked sensitive information. An attacker with access to the callback environment, such as in the case of a crafted web application, can request authentication services from this module and access to the CSRF token.

Solution

Upgrade the ruby-omniauth packages.

For the oldstable distribution (jessie), this problem has been fixed in version 1.2.1-1+deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 1.3.1-1+deb9u1.

See Also

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=888523

https://security-tracker.debian.org/tracker/ruby-omniauth

https://packages.debian.org/source/jessie/ruby-omniauth

https://packages.debian.org/source/stretch/ruby-omniauth

http://www.debian.org/security/2018/dsa-4109

Plugin Details

Severity: Medium

ID: 106727

File Name: debian_DSA-4109.nasl

Version: Revision: 3.3

Type: local

Agent: unix

Published: 2018/02/12

Modified: 2018/02/20

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSSv3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby-omniauth, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/02/09

Reference Information

CVE: CVE-2017-18076

DSA: 4109