Apache POI < 3.17 Multiple DoS Vulnerabilities

Medium Nessus Plugin ID 106717

Synopsis

The version of Apache POI installed on the remote Windows host is affected by multiple DoS vulnerabilities.

Description

The version of Apache POI installed on the remote Windows host is a version prior to 3.17. It is, therefore, affected by multiple DoS vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache POI 3.17 or later.

See Also

http://poi.apache.org/changes.html#3.17

Plugin Details

Severity: Medium

ID: 106717

File Name: apache_poi_3_17.nasl

Version: 1.2

Type: local

Agent: windows

Family: Windows

Published: 2018/02/09

Modified: 2018/08/09

Dependencies: 106718

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSSv3

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: cpe:/a:apache:poi, cpe:/a:oracle:jre, cpe:/a:oracle:jdk

Required KB Items: installed_sw/Apache POI

Patch Publication Date: 2017/09/15

Vulnerability Publication Date: 2017/07/13

Reference Information

CVE: CVE-2017-12626

BID: 102879

IAVB: 2018-B-0019