Debian DLA-1273-1 : simplesamlphp security update

High Nessus Plugin ID 106697

Synopsis

The remote Debian host is missing a security update.

Description

simplesamlphp, an authentication and federation application has been found vulnerable to Cross Site Scripting (XSS), signature validation byepass and using insecure connection charset.

CVE-2017-18121

A Cross Site Scripting (XSS) issue has been found in the consentAdmin module of SimpleSAMLphp through 1.14.15, allowing an attacker to manually craft links that a victim can open, executing arbitrary JavaScript code.

CVE-2017-18122

A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16. Service Provider using SAML 1.1 will regard as valid any unsigned SAML response containing more than one signed assertion, provided that the signature of at least one of the assertions is valid. Attributes contained in all the assertions received will be merged and the entityID of the first assertion received will be used, allowing an attacker to impersonate any user of any IdP given an assertion signed by the targeted IdP.

CVE-2018-6521

The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.

For Debian 7 'Wheezy', these problems have been fixed in version 1.9.2-1+deb7u2.

We recommend that you upgrade your simplesamlphp packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected simplesamlphp package.

See Also

https://lists.debian.org/debian-lts-announce/2018/02/msg00008.html

https://packages.debian.org/source/wheezy/simplesamlphp

Plugin Details

Severity: High

ID: 106697

File Name: debian_DLA-1273.nasl

Version: $Revision: 3.3 $

Type: local

Agent: unix

Published: 2018/02/09

Modified: 2018/02/20

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:simplesamlphp, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/02/08

Reference Information

CVE: CVE-2017-18121, CVE-2017-18122, CVE-2018-6521

OSVDB: 165067, 168103, 173927