Amazon Linux AMI : transmission (ALAS-2018-950)

Medium Nessus Plugin ID 106695

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

Transmission relies on X-Transmission-Session-Id (which is not a forbidden header for Fetch) for access control, which allows remote attackers to execute arbitrary RPC commands, and consequently write to arbitrary files, via POST requests to /transmission/rpc in conjunction with a DNS rebinding attack. (CVE-2018-5702)

Solution

Run 'yum update transmission' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2018-950.html

Plugin Details

Severity: Medium

ID: 106695

File Name: ala_ALAS-2018-950.nasl

Version: 3.3

Type: local

Agent: unix

Published: 2018/02/09

Modified: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:transmission, p-cpe:/a:amazon:linux:transmission-cli, p-cpe:/a:amazon:linux:transmission-common, p-cpe:/a:amazon:linux:transmission-daemon, p-cpe:/a:amazon:linux:transmission-debuginfo, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2018/02/07

Reference Information

CVE: CVE-2018-5702

ALAS: 2018-950