Ubuntu 17.10 : python-django vulnerabilities (USN-3559-1)

Medium Nessus Plugin ID 106675

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

It was discovered that Django incorrectly handled certain requests. An attacker could possibly use this to access sensitive information.
(CVE-2017-12794, CVE-2018-6188).

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected python-django and / or python3-django packages.

Plugin Details

Severity: Medium

ID: 106675

File Name: ubuntu_USN-3559-1.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2018/02/08

Modified: 2018/03/19

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 7.5

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:python-django, p-cpe:/a:canonical:ubuntu_linux:python3-django, cpe:/o:canonical:ubuntu_linux:17.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/02/07

Reference Information

CVE: CVE-2017-12794, CVE-2018-6188

USN: 3559-1