Debian DSA-4106-1 : libtasn1-6 - security update

medium Nessus Plugin ID 106661
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 4.4

Synopsis

The remote Debian host is missing a security-related update.

Description

Two vulnerabilities were discovered in Libtasn1, a library to manage ASN.1 structures, allowing a remote attacker to cause a denial of service against an application using the Libtasn1 library.

Solution

Upgrade the libtasn1-6 packages.

For the stable distribution (stretch), these problems have been fixed in version 4.10-1.1+deb9u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=867398

https://security-tracker.debian.org/tracker/source-package/libtasn1-6

https://packages.debian.org/source/stretch/libtasn1-6

https://www.debian.org/security/2018/dsa-4106

Plugin Details

Severity: Medium

ID: 106661

File Name: debian_DSA-4106.nasl

Version: 3.3

Type: local

Agent: unix

Published: 2/8/2018

Updated: 11/13/2018

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: Medium

VPR Score: 4.4

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libtasn1-6, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2/7/2018

Reference Information

CVE: CVE-2017-10790, CVE-2018-6003

DSA: 4106