Joomla! 1.5.0 < 3.8.4 Multiple Vulnerabilities
High Nessus Plugin ID 106631
SynopsisThe remote web server contains a PHP application that is affected by multiple vulnerabilities.
DescriptionAccording to its self-reported version number, the Joomla! installation running on the remote web server is 1.5.0 or later but prior to 3.8.4. It is, therefore, affected by multiple XSS and SQLi vulnerabilities :
- The XSS vulnerability in module chromes as noted in the 20180101 announcement affects 3.0.0 through 3.8.3.
- The XSS vulnerability in com_fields as noted in the 20180102 announcement affects 3.7.0 through 3.8.3.
- The XSS vulnerability in Uri class as noted in the 20180103 announcement affects 1.5.0 through 3.8.3.
- The SQLi vulnerability in Hathor postinstall message as noted in the 20180103 announcement affects 1.5.0 through 3.8.3. (CVE-2018-6379)
Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Joomla! version 3.8.4 or later.