Joomla! 1.5.0 < 3.8.4 Multiple Vulnerabilities

High Nessus Plugin ID 106631


The remote web server contains a PHP application that is affected by multiple vulnerabilities.


According to its self-reported version number, the Joomla! installation running on the remote web server is 1.5.0 or later but prior to 3.8.4. It is, therefore, affected by multiple XSS and SQLi vulnerabilities :

- The XSS vulnerability in module chromes as noted in the 20180101 announcement affects 3.0.0 through 3.8.3.

- The XSS vulnerability in com_fields as noted in the 20180102 announcement affects 3.7.0 through 3.8.3.

- The XSS vulnerability in Uri class as noted in the 20180103 announcement affects 1.5.0 through 3.8.3.

- The SQLi vulnerability in Hathor postinstall message as noted in the 20180103 announcement affects 1.5.0 through 3.8.3. (CVE-2018-6379)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.


Upgrade to Joomla! version 3.8.4 or later.

See Also

Plugin Details

Severity: High

ID: 106631

File Name: joomla_384.nasl

Version: $Revision: 1.4 $

Type: remote

Family: CGI abuses

Published: 2018/02/06

Modified: 2018/02/12

Dependencies: 21142

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 9.8

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/01/30

Vulnerability Publication Date: 2018/01/30

Reference Information

CVE: CVE-2018-6376, CVE-2018-6377, CVE-2018-6379, CVE-2018-6380

BID: 102916, 102917, 102918, 102921

OSVDB: 173804, 173805, 173806, 173807

IAVA: 2018-A-0047