lighttpd < 1.4.36 Multiple Vulnerabilities

Medium Nessus Plugin ID 106627

Synopsis

The remote web server is affected by a log injection vulnerability

Description

According to its banner, the version of lighttpd running on the remote host is prior to 1.4.36. It is, therefore, affected by the following vulnerabilities :

- mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to lighttpd version 1.4.36. Alternatively, apply the vendor-supplied patch.

See Also

https://jaanuskp.blogspot.in/2015/05/cve-2015-3200.html

https://www.lighttpd.net/2015/7/26/1.4.36/

Plugin Details

Severity: Medium

ID: 106627

File Name: lighttpd_1_4_36.nasl

Version: 1.3

Type: remote

Family: Web Servers

Published: 2018/02/06

Updated: 2019/01/02

Dependencies: 106628

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:U/RC:X

Vulnerability Information

CPE: cpe:/a:lighttpd:lighttpd

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/07/26

Vulnerability Publication Date: 2015/05/25

Reference Information

CVE: CVE-2015-3200

BID: 74813