lighttpd < 1.4.26 or 1.5.0 Denial of Service

medium Nessus Plugin ID 106625


The remote web server is affected by a denial of service vulnerability


According to its banner, the version of lighttpd running on the remote host is prior to 1.4.26 or is 1.5.0. It is, therefore, affected by the following vulnerabilities :

- lighttpd allocates a buffer for each read operation which allows remote attackers to cause a denial of service (memory consumption) by breaking a request into small pieces that are sent at a slow rate.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to lighttpd version 1.4.26. Alternatively, apply the vendor-supplied patch.

See Also

Plugin Details

Severity: Medium

ID: 106625

File Name: lighttpd_1_4_26.nasl

Version: 1.3

Type: remote

Family: Web Servers

Published: 2/6/2018

Updated: 1/2/2019

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 2.2


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:lighttpd:lighttpd

Required KB Items: Settings/ParanoidReport, installed_sw/lighttpd

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2/3/2010

Reference Information

CVE: CVE-2010-0295

BID: 38036

CWE: 399