OpenSSH 5.4 < 7.1p2 Multiple Vulnerabilities

Medium Nessus Plugin ID 106608


The SSH server running on the remote host is affected by multiple vulnerabilities.


According to its banner, the version of OpenSSH running on the remote host is 5.x, 6.x or 7.x prior to 7.1p2. It is, therefore, affected by multiple vulnerabilities.

- A potential information disclosure vulnerability which may allow remote servers to obtain sensitive information from process memory by requesting transmission of an entire buffer (CVE-2016-0777)

- A denial of service vulnerability due to a heap-base overflow in roaming_common.c (CVE-2016-07778)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to OpenSSH version 7.1p2 or later.

See Also

Plugin Details

Severity: Medium

ID: 106608

File Name: openssh_71p2_roaming_dos.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Misc.

Published: 2018/02/05

Modified: 2018/02/06

Dependencies: 10267

Risk Information

Risk Factor: Medium


Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:H/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/01/14

Vulnerability Publication Date: 2016/01/14

Reference Information

CVE: CVE-2016-0777, CVE-2016-0778

BID: 80695, 80698

OSVDB: 132883, 132884