Adobe Flash Player for Mac <= 28.0.0.137 Use-after-free Remote Code Execution (APSA18-01) (APSB18-03)

High Nessus Plugin ID 106607

Synopsis

The remote macOS or Mac OSX host has a browser plugin installed that is affected by a remote code execution vulnerability.

Description

The version of Adobe Flash Player installed on the remote macOS or Mac OS X host is equal or prior to version 28.0.0.137. It is, therefore, affected by a remote code execution vulnerability.

Solution

Upgrade to Adobe Flash Player version 28.0.0.161 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsa18-01.html

https://helpx.adobe.com/security/products/flash-player/apsb18-03.html

Plugin Details

Severity: High

ID: 106607

File Name: macosx_flash_player_apsa18-01.nasl

Version: 1.8

Type: local

Agent: macosx

Published: 2018/02/05

Modified: 2018/07/14

Dependencies: 53914

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/02/01

Vulnerability Publication Date: 2018/02/01

Reference Information

CVE: CVE-2018-4877, CVE-2018-4878

BID: 102893, 102930