Jenkins < 2.89.2 / 2.95 Multiple Vulnerabilities

Medium Nessus Plugin ID 106559


A job scheduling and management system hosted on the remote web server is affected by multiple vulnerabilities.


The version of Jenkins running on the remote web server is prior to 2.95 or is a version of Jenkins LTS prior to 2.89.2. It is, therefore, affected by multiple vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade Jenkins to version 2.95 or later, Jenkins LTS to version 2.89.2 or later.

See Also

Plugin Details

Severity: Medium

ID: 106559

File Name: jenkins_2_95.nasl

Version: $Revision: 1.3 $

Type: remote

Family: CGI abuses

Published: 2018/02/01

Modified: 2018/02/22

Dependencies: 65054

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 3.8

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins

Required KB Items: www/Jenkins

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/12/14

Vulnerability Publication Date: 2017/12/14

Reference Information

CVE: CVE-2017-1000503, CVE-2017-1000504

OSVDB: 170939, 170940