pfSense < 2.2.1 Multiple Vulnerabilities (SA-15_02 - SA-15_04)

Medium Nessus Plugin ID 106493


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is prior to 2.2.1. It is, therefore, affected by multiple vulnerabilities as stated in the referenced vendor advisories.


Upgrade to pfSense version 2.2.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 106493

File Name: pfsense_SA-15_04.nasl

Version: $Revision: 1.4 $

Type: remote

Family: CGI abuses

Published: 2018/01/31

Modified: 2018/02/22

Dependencies: 106952

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/03/25

Vulnerability Publication Date: 2015/03/25

Reference Information

CVE: CVE-2015-2294, CVE-2015-2295

BID: 73344