HPE Moonshot Provisioning Manager < 1.22 Multiple Vulnerabilities

Critical Nessus Plugin ID 106460


The remote host is running a web application that is affected by multiple vulnerabilities.


The HPE Moonshot Provisioning Manager running on the remote host is affected by two remote code execution vulnerabilities in the khuploadfile.cgi file due to the lack of proper validation of user-supplied data. An unauthenticated, remote attacker can exploit these issues, via a specially crafted HTTP POST message, to upload arbitrary files which could allow the attacker to execute arbitrary code.

Note that the product is reportedly affected by an additional vulnerability in the server_response.py file; however, this plugin has not tested for it.


Upgrade to HPE Moonshot Provisioning Manager v1.22 or later.

See Also




Plugin Details

Severity: Critical

ID: 106460

File Name: hpe_moonshot_provisioning_manager_hpesbhf03803_rce.nasl

Version: $Revision: 1.2 $

Type: remote

Family: CGI abuses

Published: 2018/01/29

Modified: 2018/01/31

Dependencies: 106461

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 10

Temporal Score: 9.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: x-cpe:/a:hpe:moonshot_provisioning_manager

Required KB Items: installed_sw/HPE Moonshot Provisioning Manager

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/01/03

Vulnerability Publication Date: 2018/01/03

Reference Information

CVE: CVE-2017-8975, CVE-2017-8976

BID: 102410

OSVDB: 171763, 171764

ZDI: ZDI-18-001, ZDI-18-002