WordPress 3.3.x < 3.3.1 XSS Vulnerability

Medium Nessus Plugin ID 106378


The remote web server contains a PHP application that is affected by a cross-site scripting (XSS) vulnerability.


According to its self-reported version number, the WordPress application running on the remote web server is 3.3.x prior to 3.3.1.
It is, therefore, affected by a cross-site scripting (XSS) vulnerability. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to WordPress version 3.3.1 or later.

See Also



Plugin Details

Severity: Medium

ID: 106378

File Name: wordpress_3_3_1.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2018/01/26

Updated: 2018/11/28

Dependencies: 18297

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/01/03

Vulnerability Publication Date: 2012/01/03

Reference Information

CVE: CVE-2012-0287

BID: 51237