WordPress < 3.1.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 106307

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the WordPress application running on the remote web server is prior to 3.1.1.
It is, therefore, affected by multiple vulnerabilities, including cross-site scripting (XSS) and cross-site request forgery (XSRF), and a denial of service (DoS) vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress version 3.1.1 or later.

See Also

https://wordpress.org/news/2011/04/wordpress-3-1-1/

https://codex.wordpress.org/Version_3.1.1

Plugin Details

Severity: Medium

ID: 106307

File Name: wordpress_3_1_1.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2018/01/24

Modified: 2018/05/21

Dependencies: 18297

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:U/RC:ND

CVSSv3

Base Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/04/05

Vulnerability Publication Date: 2011/04/05

Reference Information

CVE: CVE-2011-4956, CVE-2011-4957

BID: 73868, 78357