WordPress < 3.0.4 Multiple XSS Vulnerabilities

Medium Nessus Plugin ID 106306


The remote web server contains a PHP application that is affected by multiple cross-site scripting (XSS) vulnerabilities.


According to its self-reported version number, the WordPress application running on the remote web server is prior to 3.0.4.
It is, therefore, affected by multiple cross-site scripting (XSS) vulnerabilities in KSES. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to WordPress version 3.0.4 or later.

See Also



Plugin Details

Severity: Medium

ID: 106306

File Name: wordpress_3_0_4.nasl

Version: $Revision: 1.2 $

Type: remote

Family: CGI abuses

Published: 2018/01/24

Modified: 2018/01/25

Dependencies: 18297

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/12/29

Vulnerability Publication Date: 2010/12/29

Reference Information

CVE: CVE-2010-4536

BID: 45620