macOS : Apple Safari < 11.0.3 Multiple Vulnerabilities

High Nessus Plugin ID 106305


A web browser installed on the remote macOS or Mac OS X host is affected by multiple vulnerabilities.


The version of Apple Safari installed on the remote macOS or Mac OS X host is prior to 11.0.3. It is, therefore, affected by multiple vulnerabilities as described in the HT208475 security advisory.


Upgrade to Apple Safari version 11.0.3 or later.

See Also

Plugin Details

Severity: High

ID: 106305

File Name: macosx_Safari11_0_3.nasl

Version: $Revision: 1.2 $

Type: local

Agent: macosx

Published: 2018/01/24

Modified: 2018/01/26

Dependencies: 31604

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Safari/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/01/23

Vulnerability Publication Date: 2018/01/23

Reference Information

CVE: CVE-2018-4088, CVE-2018-4089, CVE-2018-4096

BID: 102775, 102778

OSVDB: 173317, 173318, 173319

APPLE-SA: APPLE-SA-2018-01-23-5