MERCUR SMTP Server EXPN Command Remote Overflow

High Nessus Plugin ID 10620


The remote SMTP server has a buffer overflow vulnerability.


It was possible to make the remote mail server crash when issuing a very long argument to the EXPN command. A remote attacker could exploit this flaw to crash the service, or possibly execute arbitrary code.


Upgrade to the latest version of this software.

See Also

Plugin Details

Severity: High

ID: 10620

File Name: mercure_expn_overflow.nasl

Version: $Revision: 1.32 $

Type: remote

Published: 2001/02/26

Modified: 2016/10/27

Dependencies: 10263

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

Vulnerability Information

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2001/02/23

Reference Information

CVE: CVE-2001-0280

BID: 2412

OSVDB: 6027