Fedora 26 : webkitgtk4 (2018-690989736a) (Spectre)

Medium Nessus Plugin ID 106178

Synopsis

The remote Fedora host is missing a security update.

Description

This update includes improvements to mitigate the effects of Spectre ([CVE-2017-5753](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-20 17-5753) and [CVE-2017-5715](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-201 7-5715)) :

- Disable SharedArrayBuffers from Web API.

- Reduce the precision of “high” resolution time to 1ms.

Additional fixes :

- Fix API documentation generation with newer gtk-doc.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora update system website.
Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected webkitgtk4 package.

See Also

https://bodhi.fedoraproject.org/updates/FEDORA-2018-690989736a

Plugin Details

Severity: Medium

ID: 106178

File Name: fedora_2018-690989736a.nasl

Version: 3.7

Type: local

Agent: unix

Published: 2018/01/19

Updated: 2019/04/05

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:webkitgtk4, cpe:/o:fedoraproject:fedora:26

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/01/18

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2017-5715, CVE-2017-5753

FEDORA: 2018-690989736a

IAVA: 2018-A-0020