EulerOS 2.0 SP2 : krb5 (EulerOS-SA-2018-1008)

High Nessus Plugin ID 106149

Synopsis

The remote EulerOS host is missing a security update.

Description

According to the version of the krb5 packages installed, the EulerOS installation on the remote host is affected by the following vulnerability :

- plugins/preauth/pkinit/pkinit_crypto_openssl.c in MIT Kerberos 5 (aka krb5) through 1.15.2 mishandles Distinguished Name (DN) fields, which allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) in situations involving untrusted X.509 data, related to the get_matching_data and X509_NAME_oneline_ex functions. (CVE-2017-15088)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected krb5 package.

See Also

http://www.nessus.org/u?9ffa40d8

Plugin Details

Severity: High

ID: 106149

File Name: EulerOS_SA-2018-1008.nasl

Version: 3.7

Type: local

Published: 2018/01/19

Modified: 2018/08/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:krb5-devel, p-cpe:/a:huawei:euleros:krb5-libs, p-cpe:/a:huawei:euleros:krb5-pkinit, p-cpe:/a:huawei:euleros:krb5-server, p-cpe:/a:huawei:euleros:krb5-server-ldap, p-cpe:/a:huawei:euleros:krb5-workstation, p-cpe:/a:huawei:euleros:libkadm5, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Excluded KB Items: Host/EulerOS/uvp_version

Patch Publication Date: 2018/01/09

Reference Information

CVE: CVE-2017-15088