VMware Tools 10.x < 10.2.0 Multiple Vulnerabilities (VMSA-2018-0003)

Medium Nessus Plugin ID 105788


A virtualization tool suite is installed on the remote Windows host is affected by multiple vulnerabilities


The version of VMware Tools installed on the remote Windows host is 10.x prior to 10.2.0. It is, therefore, affected by multiple vulnerabilities including disclosure of memory contents and a DoS.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to VMware Tools version 10.2.0 or later.

See Also



Plugin Details

Severity: Medium

ID: 105788

File Name: vmware_tools_win_vmsa_2018_0003.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2018/01/13

Modified: 2018/02/06

Dependencies: 105793, 57396

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:vmware:vmware_tools

Required KB Items: SMB/Registry/Enumerated, installed_sw/VMware Tools

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/01/04

Vulnerability Publication Date: 2018/01/04

Reference Information

CVE: CVE-2017-4945

BID: 102441

OSVDB: 172042

VMSA: 2018-0003

IAVB: 2018-B-0012