VMware vCenter Server 5.5.x < 5.5U3g / 6.0.x < 6.0U3d / 6.5.x < 6.5U1e Hypervisor-Assisted Guest Remediation (VMSA-2018-0004) (Spectre)

Medium Nessus Plugin ID 105784


The remote VMware ESXi host is missing a security patch which enables hardware support for branch target mitigation.


The version of VMware vCenter Server installed on the remote host is 5.5.x prior to 5.5U3g, 6.0.x prior to 6.0U3d, or 6.5.x prior to 6.5U1e. It is, therefore, missing security updates that add hypervisor-assisted guest remediation for a speculative execution vulnerability (CVE-2017-5715).


Upgrade to VMware vCenter Server version 5.5.U3g (5.5.0 build-7460778) / 6.0U3d (6.0.0 build-7464194) / 6.5U1e (6.5.0 build-7515524) or later.

See Also




Plugin Details

Severity: Medium

ID: 105784

File Name: vmware_vcenter_vmsa-2018-0004.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 2018/01/12

Dependencies: 63061

Risk Information

Risk Factor: Medium


Base Score: 4.7

Temporal Score: 4.5

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND


Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:X/RC:X

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Required KB Items: Host/VMware/vCenter, Host/VMware/version, Host/VMware/release

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/01/09

Vulnerability Publication Date: 2018/01/03

Reference Information

CVE: CVE-2017-5715

BID: 102376

OSVDB: 171897

VMSA: 2018-0004

IAVA: 2018-A-0020