Security Update for .NET Core (January 2018) (macOS)

High Nessus Plugin ID 105729


An application installed on the remote macOS or Mac OS X host is affected by a denial of service vulnerability.


The Microsoft .NET Core runtime installed on the remote macOS or Mac OS X host is missing a security update. It is, therefore, affected by multiple vulnerabilities :

- A security feature bypass in X509 Certificate Validation allows an attacker to present a certificate that is marked as invalid for a specific use, but a component uses it for that purpose. (CVE-2018-0786)

- A denial of service vulnerability exists due to improper processing of XML documents. An attacker who successfully exploited this vulnerability could cause a denial of service against a .NET application. A remote unauthenticated attacker could exploit this vulnerability by issuing specially crafted requests to a .NET Core application. (CVE-2018-0764)


Upgrade to .NET Core Runtime version 1.0.9 / 1.1.6 / 2.0.5 or later.

See Also

Plugin Details

Severity: High

ID: 105729

File Name: macosx_ms18_jan_dotnet_core.nasl

Version: 1.4

Type: local

Agent: macosx

Published: 2018/01/10

Modified: 2018/03/16

Dependencies: 104666

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:.net_core

Required KB Items: installed_sw/.NET Core MacOS

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/01/09

Vulnerability Publication Date: 2018/01/09

Reference Information

CVE: CVE-2018-0786, CVE-2018-0764

OSVDB: 172253, 172259