Adobe Flash Player <= 28.0.0.126 (APSB18-01)

High Nessus Plugin ID 105691

Synopsis

The remote Windows host has a browser plugin installed that is affected by an out-of-bounds read vulnerability.

Description

The version of Adobe Flash Player installed on the remote Windows host is equal or prior to version 28.0.0.126. It is, therefore, affected by a an out-of-bounds read vulnerability.

Solution

Upgrade to Adobe Flash Player version 28.0.0.137 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-01.html

Plugin Details

Severity: High

ID: 105691

File Name: flash_player_apsb18-01.nasl

Version: 1.6

Type: local

Agent: windows

Family: Windows

Published: 2018/01/09

Modified: 2018/07/12

Dependencies: 28211

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.1

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/01/09

Vulnerability Publication Date: 2018/01/09

Reference Information

CVE: CVE-2018-4871

BID: 102465