Asterisk 13.x < 13.18.5 / 14.x < 14.7.5 / 15.x < 15.1.5 / 13.13 < 13.18-cert2 Crash in PJSIP (AST-2017-014)
Medium Nessus Plugin ID 105545
SynopsisA telephony application running on the remote host is affected by a remote denial of service vulnerability.
DescriptionAccording to its SIP banner, the version of Asterisk running on the remote host is 13.x prior to 13.18.5, 14.x prior to 14.7.5, 15.x prior to 15.1.5, or 13.18 prior to 13.18-cert2. It is therefore, affected by a remote denial of service attack as described in AST-2017-014.
Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Asterisk version 13.18.5 / 14.7.5 / 15.1.4 / 13.18-cert2 or later.