Asterisk 13.x < 13.18.5 / 14.x < 14.7.5 / 15.x < 15.1.5 / 13.13 < 13.18-cert2 Crash in PJSIP (AST-2017-014)

Medium Nessus Plugin ID 105545


A telephony application running on the remote host is affected by a remote denial of service vulnerability.


According to its SIP banner, the version of Asterisk running on the remote host is 13.x prior to 13.18.5, 14.x prior to 14.7.5, 15.x prior to 15.1.5, or 13.18 prior to 13.18-cert2. It is therefore, affected by a remote denial of service attack as described in AST-2017-014.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Asterisk version 13.18.5 / 14.7.5 / 15.1.4 / 13.18-cert2 or later.

See Also

Plugin Details

Severity: Medium

ID: 105545

File Name: asterisk_ast_2017_014.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 2018/01/04

Updated: 2019/11/08

Dependencies: 63202

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-17850

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/12/13

Vulnerability Publication Date: 2017/12/12

Reference Information

CVE: CVE-2017-17850