Debian DSA-4076-1 : asterisk - security update

Medium Nessus Plugin ID 105498


The remote Debian host is missing a security-related update.


Multiple vulnerabilities have been discovered in Asterisk, an open source PBX and telephony toolkit, which may result in denial of service, information disclosure and potentially the execution of arbitrary code.


Upgrade the asterisk packages.

For the oldstable distribution (jessie), these problems have been fixed in version 1:11.13.1~dfsg-2+deb8u5.

For the stable distribution (stretch), these problems have been fixed in version 1:13.14.1~dfsg-2+deb9u3.

See Also

Plugin Details

Severity: Medium

ID: 105498

File Name: debian_DSA-4076.nasl

Version: $Revision: 3.2 $

Type: local

Agent: unix

Published: 2018/01/02

Modified: 2018/01/29

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:asterisk, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2017/12/30

Reference Information

CVE: CVE-2017-16671, CVE-2017-16672, CVE-2017-17090, CVE-2017-17664

DSA: 4076