Xen PV Guests Internally Used Pages Access Handling Guest-to-Host Privilege Escalation (XSA-248)

Medium Nessus Plugin ID 105490

Synopsis

The remote Xen hypervisor installation is missing a security update.

Description

According to its self-reported version number, the Xen hypervisor installed on the remote host is affected by a guest-to-host privilege escalation vulnerability.

Note that Nessus has checked the changeset versions based on the xen.git change log. Nessus did not check guest hardware configurations or if patches were applied manually to the source code before a recompile and reinstall.

Solution

Apply the appropriate patch according to the vendor advisory.

See Also

http://xenbits.xen.org/xsa/advisory-248.html

https://xenbits.xen.org/gitweb/?p=xen.git;a=summary

Plugin Details

Severity: Medium

ID: 105490

File Name: xen_server_XSA-248.nasl

Version: $Revision: 1.4 $

Type: local

Family: Misc.

Published: 2017/12/29

Modified: 2018/01/04

Dependencies: 78089

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.9

Temporal Score: 5.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.4

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/o:xen:xen

Required KB Items: installed_sw/Xen Hypervisor, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/12/12

Vulnerability Publication Date: 2017/12/12

Reference Information

CVE: CVE-2017-17566

OSVDB: 170831

IAVB: 2018-B-0007