Debian DSA-4070-1 : enigmail - security update

High Nessus Plugin ID 105430

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities were discovered in Enigmail, an OpenPGP extension for Thunderbird, which could result in a loss of confidentiality, faked signatures, plain text leaks and denial of service. Additional information can be found under https://enigmail.net/download/other/Enigmail%20Pentest%20Report%20by%2 0Cure53%20-%20Excerpt.pdf

Solution

Upgrade the enigmail packages.

For the oldstable distribution (jessie), this problem has been fixed in version 2:1.9.9-1~deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 2:1.9.9-1~deb9u1.

See Also

http://www.nessus.org/u?6620e35f

https://security-tracker.debian.org/tracker/source-package/enigmail

https://packages.debian.org/source/jessie/enigmail

https://packages.debian.org/source/stretch/enigmail

https://www.debian.org/security/2017/dsa-4070

Plugin Details

Severity: High

ID: 105430

File Name: debian_DSA-4070.nasl

Version: 3.8

Type: local

Agent: unix

Published: 2017/12/26

Updated: 2019/05/07

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 4.4

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:enigmail, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/12/21

Reference Information

CVE: CVE-2017-17843, CVE-2017-17844, CVE-2017-17845, CVE-2017-17846, CVE-2017-17847, CVE-2017-17848

DSA: 4070