Debian DLA-1222-1 : ruby1.8 security update

High Nessus Plugin ID 105429

Synopsis

The remote Debian host is missing a security update.

Description

Several vulnerabilities have been discovered in the interpreter for the Ruby language. The Common Vulnerabilities and Exposures project identifies the following problems :

CVE-2017-17405

A command injection vulnerability in Net::FTP might allow a malicious FTP server the execution of arbitrary commands.

CVE-2017-17790

A command injection vulnerability in lib/resolv.rb's lazy_initialze might allow a command injection attack. However untrusted input to this function is rather unlikely.

For Debian 7 'Wheezy', these problems have been fixed in version 1.8.7.358-7.1+deb7u5.

We recommend that you upgrade your ruby1.8 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2017/12/msg00024.html

https://packages.debian.org/source/wheezy/ruby1.8

Plugin Details

Severity: High

ID: 105429

File Name: debian_DLA-1222.nasl

Version: 3.3

Type: local

Agent: unix

Published: 2017/12/26

Updated: 2018/07/06

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libruby1.8, p-cpe:/a:debian:debian_linux:libruby1.8-dbg, p-cpe:/a:debian:debian_linux:libtcltk-ruby1.8, p-cpe:/a:debian:debian_linux:ri1.8, p-cpe:/a:debian:debian_linux:ruby1.8, p-cpe:/a:debian:debian_linux:ruby1.8-dev, p-cpe:/a:debian:debian_linux:ruby1.8-examples, p-cpe:/a:debian:debian_linux:ruby1.8-full, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/12/25

Reference Information

CVE: CVE-2017-17405, CVE-2017-17790