Citrix NetScaler Multiple Vulnerabilities (CTX230238, CTX230612)

medium Nessus Plugin ID 105373
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote device is affected by multiple vulnerabilities.

Description

The remote Citrix NetScaler device is affected by multiple vulnerabilities in the Application Delivery Controller (ADC) and the Gateway Management Interface. Please refer to advisories CTX230238 and CTX230612 for more information.

Solution

Upgrade to Citrix NetScaler ADC and Gateway version 10.5 build 67.13 / 11.0 build 71.22 / 11.1 build 56.19 / 12.0 build 53.22 or later.

See Also

https://support.citrix.com/article/CTX230238

https://support.citrix.com/article/CTX230612

Plugin Details

Severity: Medium

ID: 105373

File Name: citrix_netscaler_CTX230612.nasl

Version: 1.5

Type: combined

Family: CGI abuses

Published: 12/19/2017

Updated: 11/12/2019

Dependencies: citrix_netscaler_detect.nbin

Risk Information

CVSS Score Source: CVE-2017-17549

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:citrix:netscaler_application_delivery_controller_firmware, cpe:/o:citrix:netscaler_access_gateway_firmware

Required KB Items: Host/NetScaler/Detected

Exploit Ease: No known exploits are available

Patch Publication Date: 12/12/2017

Vulnerability Publication Date: 12/12/2017

Reference Information

CVE: CVE-2017-17382, CVE-2017-17549

BID: 102173, 102177