Atlassian Bamboo 6.1.x < 6.1.6 / 6.2.x < 6.2.5 Incorrect Permission Check RCE

critical Nessus Plugin ID 105371

Synopsis

The remote web application is affected by a remote code execution vulnerability.

Description

According to its self-reported version number, the instance of Atlassian Bamboo running on the remote host is 6.1.x prior to 6.1.6 or 6.2.x prior to 6.2.5. It is, therefore, affected by multiple remote code execution vulnerabilities.

Solution

Upgrade to Atlassian Bamboo version 6.1.6 / 6.2.5 or later.

See Also

http://www.nessus.org/u?33dffba7

Plugin Details

Severity: Critical

ID: 105371

File Name: bamboo_6_2_5.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 12/19/2017

Updated: 6/4/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.5

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2017-14590

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:bamboo

Required KB Items: Settings/ParanoidReport, installed_sw/bamboo

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No known exploits are available

Patch Publication Date: 6/14/2017

Vulnerability Publication Date: 6/14/2017

Reference Information

CVE: CVE-2017-14589, CVE-2017-14590

BID: 102188, 102193