VLC Media Player < 2.2.7 Overflow Condition

High Nessus Plugin ID 105294

Synopsis

A media player installed on the remote host is affected by an overflow condition.

Description

The version of VLC media player installed on the remote host is prior to 2.2.7. It is, therefore, affected by an overflow condition in the lavc_GetVideoFormat() function in modules/codec/avcodec/video.c.
This vulnerability can cause a denial of service and potentially allow remote code execution.

Solution

Upgrade to VLC version 2.2.7 or later.

See Also

https://trac.videolan.org/vlc/ticket/18467#no1

Plugin Details

Severity: High

ID: 105294

File Name: vlc_2_2_7.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 2017/12/15

Modified: 2018/08/07

Dependencies: 31852

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: installed_sw/VLC media player

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/11/21

Vulnerability Publication Date: 2017/07/28

Reference Information

CVE: CVE-2017-10699