OpenSSL 1.1.0 < 1.1.0h AVX2 Montgomery Multiplication Private Key Derivation Weakness

medium Nessus Plugin ID 105292
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A service running on the remote host is affected by an information disclosure vulnerability.

Description

According to its banner, the version of OpenSSL running on the remote host is 1.1.0 prior to 1.1.0h. It is, therefore, affected by multiple vulnerabilities.

Solution

Apply the vendor patch or upgrade to OpenSSL version 1.1.0h or later.

See Also

https://www.openssl.org/news/secadv/20171207.txt

https://www.openssl.org/news/secadv/20180327.txt

Plugin Details

Severity: Medium

ID: 105292

File Name: openssl_1_1_0h.nasl

Version: 1.9

Type: remote

Family: Web Servers

Published: 12/15/2017

Updated: 11/12/2019

Dependencies: openssl_version.nasl

Risk Information

CVSS Score Source: CVE-2017-3738

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Ease: No known exploits are available

Patch Publication Date: 12/7/2017

Vulnerability Publication Date: 12/7/2017

Reference Information

CVE: CVE-2017-3738, CVE-2018-0739

BID: 102118, 103518