GLSA-201712-02 : OpenCV: Multiple vulnerabilities

High Nessus Plugin ID 105262


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201712-02 (OpenCV: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in OpenCV. Please review the referenced CVE identifiers for details.
Impact :

An attacker can cause a denial of service condition or conduct other memory corruption attacks.
Workaround :

There are no known workarounds at this time.


All OpenCV users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/opencv-2.4.13-r3'

See Also

Plugin Details

Severity: High

ID: 105262

File Name: gentoo_GLSA-201712-02.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2017/12/15

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:opencv, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/12/14

Reference Information

CVE: CVE-2017-12597, CVE-2017-12598, CVE-2017-12599, CVE-2017-12600, CVE-2017-12601, CVE-2017-12602, CVE-2017-12603, CVE-2017-12604, CVE-2017-12605, CVE-2017-12606, CVE-2017-12862, CVE-2017-12863, CVE-2017-12864, CVE-2017-14136

GLSA: 201712-02