Debian DSA-4060-1 : wireshark - security update

Medium Nessus Plugin ID 105121

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that wireshark, a network protocol analyzer, contained several vulnerabilities in the dissectors for CIP Safety, IWARP_MPA, NetBIOS, Profinet I/O and AMQP, which result in denial of dervice or the execution of arbitrary code.

Solution

Upgrade the wireshark packages.

For the oldstable distribution (jessie), these problems have been fixed in version 1.12.1+g01b65bf-4+deb8u12.

For the stable distribution (stretch), these problems have been fixed in version 2.2.6+g32dac6a-2+deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/wireshark

https://packages.debian.org/source/jessie/wireshark

https://packages.debian.org/source/stretch/wireshark

https://www.debian.org/security/2017/dsa-4060

Plugin Details

Severity: Medium

ID: 105121

File Name: debian_DSA-4060.nasl

Version: 3.7

Type: local

Agent: unix

Published: 2017/12/11

Updated: 2019/04/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:wireshark, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/12/09

Reference Information

CVE: CVE-2017-11408, CVE-2017-13766, CVE-2017-17083, CVE-2017-17084, CVE-2017-17085

DSA: 4060