TeamViewer Permissions Vulnerability (macOS)

Medium Nessus Plugin ID 105110


The remote macOS or Mac OS X host contains an application that is affected by a permissions vulnerability.


According to its version number, the TeamViewer install on the remote macOS or Mac OS X host is a version prior to 11.0.73955, 12.0.82953, or 13.0.5640.
It is, therefore, affected by a permissions vulnerability than can result in unauthorized remote control.

During an authenticated connection it may be possible for an attacker to control the mouse without regard for the server's current control setting. This can be exploited from both the viewer and presenter roles, enabling the viewer to control the presenters mouse or enabling the 'switch sides' feature without requiring the client to agree.


Upgrade to TeamViewer 11.0.73955 / 12.0.82953 / 13.0.5640 or later.

See Also

Plugin Details

Severity: Medium

ID: 105110

File Name: macos_teamviewer_perm_hook.nasl

Version: $Revision: 1.2 $

Type: local

Agent: macosx

Published: 2017/12/08

Modified: 2017/12/11

Dependencies: 105111

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:teamviewer:teamviewer

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/TeamViewer

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/12/05

Vulnerability Publication Date: 2017/12/04

Reference Information

OSVDB: 170442