IBM WebSphere MQ 7.5.x / 8.0.0.x < 8.0.0.8 / 9.0.x < 9.0.4 / 9.0.0.x < 9.0.0.2 Multiple Vulnerabilities

low Nessus Plugin ID 105082
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A message queuing service installed on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version, the IBM WebSphere MQ server installed on the remote Windows host is 7.5.x without patch APAR IT15943, 8.0.0.x prior to 8.0.0.8, 9.0.x prior to 9.0.4, or 9.0.0.x prior to 9.0.0.2. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to WebSphere MQ version 8.0.0.8 / 9.0.4 / 9.0.0.2 or later.
- For version 7.5.x, apply the patch APAR IT15943.

See Also

https://www-01.ibm.com/support/docview.wss?uid=swg22005400

https://www-01.ibm.com/support/docview.wss?uid=swg22005525

Plugin Details

Severity: Low

ID: 105082

File Name: websphere_mq_swg22005525.nasl

Version: 1.5

Type: local

Agent: windows

Family: Windows

Published: 12/7/2017

Updated: 8/7/2018

Dependencies: websphere_mq_installed.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_mq

Required KB Items: installed_sw/IBM WebSphere MQ, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 11/30/2017

Vulnerability Publication Date: 11/30/2017

Reference Information

CVE: CVE-2017-1341, CVE-2017-1433

BID: 102042