Amazon Linux AMI : apr-util (ALAS-2017-929)

Low Nessus Plugin ID 105053


The remote Amazon Linux AMI host is missing a security update.


Apache Portable Runtime Utility (APR-util) fails to validate the integrity of SDBM database files used by apr_sdbm*() functions, resulting in a possible out of bound read access. A local user with write access to the database can make a program or process using these functions crash, and cause a denial of service.(CVE-2017-12618)


Run 'yum update apr-util' to update your system.

See Also

Plugin Details

Severity: Low

ID: 105053

File Name: ala_ALAS-2017-929.nasl

Version: $Revision: 3.2 $

Type: local

Agent: unix

Published: 2017/12/07

Modified: 2018/01/25

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:N/A:P


Base Score: 4.7

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:apr-util, p-cpe:/a:amazon:linux:apr-util-debuginfo, p-cpe:/a:amazon:linux:apr-util-devel, p-cpe:/a:amazon:linux:apr-util-freetds, p-cpe:/a:amazon:linux:apr-util-ldap, p-cpe:/a:amazon:linux:apr-util-mysql, p-cpe:/a:amazon:linux:apr-util-nss, p-cpe:/a:amazon:linux:apr-util-odbc, p-cpe:/a:amazon:linux:apr-util-openssl, p-cpe:/a:amazon:linux:apr-util-pgsql, p-cpe:/a:amazon:linux:apr-util-sqlite, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2017/12/05

Reference Information

CVE: CVE-2017-12618

ALAS: 2017-929