Amazon Linux AMI : apr (ALAS-2017-928)

Low Nessus Plugin ID 105052

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

An out-of-bounds array dereference was found in apr_time_exp_get(). An attacker could abuse an unvalidated usage of this function to cause a denial of service or potentially lead to data leak.(CVE-2017-12613)

Solution

Run 'yum update apr' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2017-928.html

Plugin Details

Severity: Low

ID: 105052

File Name: ala_ALAS-2017-928.nasl

Version: 3.3

Type: local

Agent: unix

Published: 2017/12/07

Modified: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:P

CVSSv3

Base Score: 7.1

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:apr, p-cpe:/a:amazon:linux:apr-debuginfo, p-cpe:/a:amazon:linux:apr-devel, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2017/12/05

Reference Information

CVE: CVE-2017-12613

ALAS: 2017-928