Wireshark 2.2.x < 2.2.11 / 2.4.x < 2.4.3 DoS Vulnerabilities

High Nessus Plugin ID 105007


An application installed on the remote Windows host is affected by multiple denial of service vulnerabilities.


The version of Wireshark installed on the remote Windows host is 2.2.x prior to 2.2.11 or 2.4.x prior to 2.4.3. It is, therefore, affected by denial of service vulnerabilities in the IWARP_MPA, NetBIOS, and CIP Safety dissectors. An unauthenticated, remote attacker can exploit this by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Wireshark version 2.2.11 / 2.4.3 or later.

See Also




Plugin Details

Severity: High

ID: 105007

File Name: wireshark_2_4_3.nasl

Version: 3.6

Type: local

Agent: windows

Family: Windows

Published: 2017/12/01

Updated: 2018/08/07

Dependencies: 34112

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: installed_sw/Wireshark, SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/11/30

Vulnerability Publication Date: 2017/11/30

Reference Information

CVE: CVE-2017-17083, CVE-2017-17084, CVE-2017-17085