Apache Struts 2.5.x < 2.5.14.1 Json-lib JSON Parsing Unspecified DoS (S2-054) (S2-055)

High Nessus Plugin ID 105005

Synopsis

A web application running on the remote host uses a Java framework that is affected by multiple vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.5.x prior to 2.5.14.1. It is, therefore, affected by an unspecified flaw that is triggered when parsing JSON. This allows a remote attacker to cause a denial of service.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.5.14.1 or later or apply the workaround as referenced in the vendor's security bulletin.

See Also

https://cwiki.apache.org/confluence/display/WW/Version+Notes+2.5.14.1

https://cwiki.apache.org/confluence/display/WW/S2-054

https://cwiki.apache.org/confluence/display/WW/S2-055

Plugin Details

Severity: High

ID: 105005

File Name: struts_2_5_14_1.nasl

Version: 1.12

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 2017/12/04

Updated: 2019/11/12

Dependencies: 11936, 73943, 122235, 99671

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-7525

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/11/29

Vulnerability Publication Date: 2017/11/29

Reference Information

CVE: CVE-2017-7525, CVE-2017-15707

BID: 99623, 102021