Security Updates for Internet Explorer (June 2017)

High Nessus Plugin ID 104892

Synopsis

The Internet Explorer installation on the remote host is affected by multiple vulnerabilities.

Description

The Internet Explorer installation on the remote host is missing security updates. It is, therefore, affected by multiple vulnerabilities :

- A remote code execution vulnerability exists when Internet Explorer improperly accesses objects in memory.
This vulnerability could corrupt memory in such a way that an attacker could execute arbitrary code in the context of the current user. (CVE-2017-8519, CVE-2017-8547)

- A remote code execution vulnerability exists in the way JavaScript engines render when handling objects in memory in Microsoft browsers. The vulnerability could corrupt memory in such a way that an attacker could execute arbitrary code in the context of the current user. An attacker who successfully exploited the vulnerability could gain the same user rights as the current user. (CVE-2017-8517, CVE-2017-8522, CVE-2017-8524)

Solution

Microsoft has released security updates for the affected versions of Internet Explorer.

See Also

http://www.nessus.org/u?5f83ad76

http://www.nessus.org/u?4a3cabfc

http://www.nessus.org/u?f2d033c7

http://www.nessus.org/u?43db6287

http://www.nessus.org/u?1f6a3c24

Plugin Details

Severity: High

ID: 104892

File Name: smb_nt_ms17_jun_internet_explorer.nasl

Version: 1.10

Type: local

Agent: windows

Published: 2017/11/30

Updated: 2018/10/04

Dependencies: 13855, 93962, 57033

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-8517

CVSS v2.0

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows, cpe:/a:microsoft:ie

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/06/13

Vulnerability Publication Date: 2017/06/13

Reference Information

CVE: CVE-2017-8517, CVE-2017-8519, CVE-2017-8522, CVE-2017-8524, CVE-2017-8547, CVE-2017-8529

BID: 98895, 98899, 98926, 98930, 98932

MSKB: 4022726, 4022724, 4021558, 4022719

MSFT: MS17-4022726, MS17-4022724, MS17-4021558, MS17-4022719