VMware Fusion 8.x < 8.5.9 Multiple Vulnerabilities (VMSA-2017-0018) (macOS)

High Nessus Plugin ID 104851


A virtualization application installed on the remote macOS or Mac OS X host is affected by a code execution vulnerability.


The version of VMware Fusion installed on the remote macOS or Mac OS X host is 8.x prior to 8.5.9. It is, therefore, affected by multiple vulnerabilities that allow arbitrary code execution or crashing of VMs.


Upgrade to VMware Fusion version 8.5.9 or later.

See Also




Plugin Details

Severity: High

ID: 104851

File Name: macosx_fusion_vmsa_2017_0018.nasl

Version: $Revision: 1.4 $

Type: local

Agent: macosx

Published: 2017/11/29

Modified: 2018/01/18

Dependencies: 50828

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:vmware:fusion

Required KB Items: Host/local_checks_enabled, installed_sw/VMware Fusion

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/16

Vulnerability Publication Date: 2017/11/16

Reference Information

CVE: CVE-2017-4934, CVE-2017-4938, CVE-2017-4939

BID: 101903, 101887

OSVDB: 169506, 169508, 169509, 169510

VMSA: 2017-0018

ZDI: ZDI-17-921, ZDI-17-922