Debian DSA-4050-1 : xen - security update

High Nessus Plugin ID 104819

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities have been discovered in the Xen hypervisor, which could result in denial of service, information leaks, privilege escalation or the execution of arbitrary code.

Solution

Upgrade the xen packages.

For the oldstable distribution (jessie) a separate update will be released.

For the stable distribution (stretch), these problems have been fixed in version 4.8.2+xsa245-0+deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/xen

https://packages.debian.org/source/stretch/xen

https://www.debian.org/security/2017/dsa-4050

Plugin Details

Severity: High

ID: 104819

File Name: debian_DSA-4050.nasl

Version: 3.7

Type: local

Agent: unix

Published: 2017/11/29

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:xen, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/11/28

Reference Information

CVE: CVE-2017-14316, CVE-2017-14317, CVE-2017-14318, CVE-2017-14319, CVE-2017-15588, CVE-2017-15589, CVE-2017-15590, CVE-2017-15592, CVE-2017-15593, CVE-2017-15594, CVE-2017-15595, CVE-2017-15597, CVE-2017-17044, CVE-2017-17045, CVE-2017-17046

DSA: 4050