GLSA-201711-16 : CouchDB: Multiple vulnerabilities

Critical Nessus Plugin ID 104697

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201711-16 (CouchDB: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in CouchDB. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could execute arbitrary shell commands or escalate privileges.
Workaround :

There is no known workaround at this time.

Solution

All CouchDB users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-db/couchdb-1.7.1'

See Also

https://security.gentoo.org/glsa/201711-16

Plugin Details

Severity: Critical

ID: 104697

File Name: gentoo_GLSA-201711-16.nasl

Version: $Revision: 3.4 $

Type: local

Published: 2017/11/20

Modified: 2018/03/01

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:couchdb, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/11/19

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2017-12635, CVE-2017-12636

GLSA: 201711-16