Asterisk 13.x < 13.18.1 / 14.x < 14.7.1 / 15.x < 15.1.1 / 13.13 < 13.13-cert7 Multiple Vulnerabilities (AST-2017-009 - AST-2017-011)

High Nessus Plugin ID 104658

Synopsis

A telephony application running on the remote host is affected by multiple vulnerabilities.

Description

According to its SIP banner, the version of Asterisk running on the remote host is 13.x prior to 13.18.1, 14.x prior to 14.7.1, 15.x prior to 15.1.1, or 13.13 prior to 13.13-cert7. It is therefore, affected by multiple vulnerabilities as described in AST-2017-009, AST-2017-010, and AST-2017-011.

Also note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Asterisk version 13.18.1 / 14.7.1 / 15.1.1 / 13.13-cert7 or later.

See Also

http://downloads.asterisk.org/pub/security/AST-2017-009.html

http://downloads.asterisk.org/pub/security/AST-2017-010.html

http://downloads.asterisk.org/pub/security/AST-2017-011.html

Plugin Details

Severity: High

ID: 104658

File Name: asterisk_ast_2017_009-011.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 2017/11/17

Updated: 2018/06/29

Dependencies: 63202

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/08

Vulnerability Publication Date: 2017/10/03

Reference Information

CVE: CVE-2017-16671, CVE-2017-16672

BID: 101759, 101760, 101765