Tenable SecurityCenter PHP < 5.6.32 PCRE DoS

critical Nessus Plugin ID 104640
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The Tenable SecurityCenter application on the remote host contains a PHP library that is affected by a denial of service vulnerability.

Description

The Tenable SecurityCenter application installed on the remote host is missing a security patch. It is, therefore, affected by a PCRE denial of service vulnerability in the bundled version of PHP.

Solution

Upgrade to Tenable SecurityCenter version 5.6.0.1 or later.
Alternatively, apply SecurityCenter Patch SC-201711.1-5.x.

See Also

http://www.nessus.org/u?fbaac4f6

http://php.net/ChangeLog-5.php#5.6.32

https://bugs.exim.org/show_bug.cgi?id=1767

Plugin Details

Severity: Critical

ID: 104640

File Name: securitycenter_php_5_6_32.nasl

Version: 1.6

Type: combined

Agent: unix

Family: Misc.

Published: 11/16/2017

Updated: 10/9/2020

Dependencies: securitycenter_installed.nbin, securitycenter_detect.nbin

Risk Information

CVSS Score Source: CVE-2016-1283

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Required KB Items: Host/SecurityCenter/Version, installed_sw/SecurityCenter, Host/SecurityCenter/support/php/version

Exploit Ease: No known exploits are available

Patch Publication Date: 2/27/2016

Vulnerability Publication Date: 1/2/2016

Reference Information

CVE: CVE-2016-1283

BID: 79825