PHP 7.1.x < 7.1.11 Multiple Vulnerabilities

critical Nessus Plugin ID 104633
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.11. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to PHP version 7.1.11 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.11

Plugin Details

Severity: Critical

ID: 104633

File Name: php_7_1_11.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 11/16/2017

Updated: 11/12/2019

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2016-1283

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Required KB Items: www/PHP

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 10/26/2017

Vulnerability Publication Date: 10/26/2017

Reference Information

CVE: CVE-2017-16642, CVE-2016-1283

BID: 79825, 101745