PHP 7.0.x < 7.0.25 Multiple Vulnerabilities

High Nessus Plugin ID 104632

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.25. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to PHP version 7.0.25 or later.

See Also

http://php.net/ChangeLog-7.php#7.0.25

Plugin Details

Severity: High

ID: 104632

File Name: php_7_0_25.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2017/11/16

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2017/10/26

Vulnerability Publication Date: 2017/10/26

Reference Information

CVE: CVE-2016-1283, CVE-2017-16642

BID: 79825, 101745